GitHub header

US - Copilot Metrics unaccessible

Incident Report for GitHub Enterprise Cloud US

Resolved

This incident has been resolved. Thank you for your patience and understanding as we addressed this issue. A detailed root cause analysis will be shared as soon as it is available.
Posted Mar 12, 2026 - 16:14 UTC

Update

Our database infrastructure has recovered and affected services are now operational. Users can access Copilot usage metrics, billing usage reports, action usage metrics, and API Insights. We are continuing to monitor service stability closely.
Posted Mar 12, 2026 - 16:14 UTC

Update

Beginning at approximately 1:20pm UTC, users are unable to access Copilot usage metrics, billing usage reports, action usage metrics, and API Insights due to database infrastructure issues. Recovery is in progress. We are monitoring progress closely. We'll post another update by 5:30pm UTC.
Posted Mar 12, 2026 - 15:52 UTC

Update

Beginning at approximately 1:20pm UTC, users are unable to access Copilot usage metrics and dashboards. We are investigating the root cause and working to restore service. We'll post another update by 3:30pm UTC.
Posted Mar 12, 2026 - 15:00 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Mar 12, 2026 - 14:58 UTC