GitHub header

US - Disruption with some GitHub services

Incident Report for GitHub Enterprise Cloud US

Resolved

On November 12, 2025, between 22:10 UTC and 23:04 UTC, Codespaces used internally at GitHub were impacted. There was no impact to external customers. The scope of impact was not clear in the initial steps of incident response, so it was considered public until confirmed otherwise. One improvement from this will be improved clarity of internal versus public impact for similar failures to better inform our status decisions going forward.
Posted Nov 12, 2025 - 23:04 UTC

Update

We are continuing to investigate connectivity issues with codespaces
Posted Nov 12, 2025 - 22:51 UTC

Update

We are investing reports of codespaces no longer appearing in the UI or API. Users may experience connectivity issues to the impacted codespaces.
Posted Nov 12, 2025 - 22:26 UTC

Investigating

We are currently investigating this issue.
Posted Nov 12, 2025 - 22:26 UTC