From Nov 17, 2025 00:00 UTC to Nov 17, 2025 15:00 UTC Dependabot was hitting a rate limit in GitHub Container Registry (GHCR) and was unable to complete about 57% of jobs.
To mitigate the issue we lowered the rate at which Dependabot started jobs and increased the GHCR rate limit.
We’re adding new monitors and alerts and looking into more ways to decrease load on GHCR to help prevent this in the future.
Posted Nov 17, 2025 - 19:08 UTC
Update
We continue to see recovery and dependabot jobs are currently processing as expected.
Posted Nov 17, 2025 - 18:54 UTC
Update
We are applying a configuration change and will monitor for recovery.
Posted Nov 17, 2025 - 18:18 UTC
Update
We are continuing to investigate dependabot failures and a configuration change to mitigate.
Posted Nov 17, 2025 - 17:50 UTC
Update
We are investigating dependabot job failures affecting approximately 50% of version updates and 25% of security updates.