GitHub header

US - Disruption with some GitHub services regarding file upload

Incident Report for GitHub Enterprise Cloud US

Resolved

On February 13, 2026, between 21:46 UTC and 22:58 UTC (72 minutes), the GitHub file upload service was degraded and users uploading from a web browser on GitHub.com were unable to upload files to repositories, create release assets, or upload manifest files. During the incident, successful upload completions dropped by ~85% from baseline levels. This was due to a code change that inadvertently modified browser request behavior and violated CORS (Cross-Origin Resource Sharing) policy requirements, causing upload requests to be blocked before reaching the upload service.

We mitigated the incident by reverting the code change that introduced the issue.

We are working to improve automated testing for browser-side request changes and to add monitoring/automated safeguards for upload flows to reduce our time to detection and mitigation of similar issues in the future.
Posted Feb 13, 2026 - 22:58 UTC

Investigating

We are investigating reports of impacted performance for some GitHub services.
Posted Feb 13, 2026 - 22:30 UTC