Between February 11th 21:30 UTC and February 12th 15:40 UTC, users in Western Europe experienced degraded quality for all Next Edit Suggestions requests. Additionally, on February 12th, between 18:40 UTC and 20:30 UTC, users in Australia and South America experienced degraded quality and increased latency of up to 500ms for all Next Edit Suggestions requests. The root cause was a newly introduced regression in an upstream service dependency.
The incident was mitigated by failing over Next Edit Suggestions traffic to unaffected regions, which caused the increased latency. Once the regression was identified and rolled back, we restored the impacted capacity. We have improved our quality analysis tooling and are working on more robust quality impact alerting to accelerate detection of these issues in the future.
Posted Feb 12, 2026 - 16:50 UTC
Update
We are experiencing degraded availability in Western Europe for Copilot completions and suggestions. We are working to resolve the issue.
Posted Feb 12, 2026 - 15:33 UTC
Update
We are experiencing degraded availability in some regions for Copilot completions and suggestions. We are working to resolve the issue.
Posted Feb 12, 2026 - 14:08 UTC
Investigating
We are investigating reports of impacted performance for some GitHub services.