GitHub header

US - Experiencing connection issues across Actions, Codespaces, and possibly other services

Incident Report for GitHub Enterprise Cloud US

Resolved

On October 29th, 2025 between 14:07 UTC and 23:15 UTC, multiple GitHub services were degraded due to a broad outage in one of our service providers:

- Users of Codespaces experienced failures connecting to new and existing Codespaces through VSCode Desktop or Web. On average the Codespace connection error rate was 90% and peaked at 100% across all regions throughout the incident period.
- GitHub Actions larger hosted runners experienced degraded performance, with 0.5% of overall workflow runs and 9.8% of larger hosted runner jobs failing or not starting within 5 minutes. These recovered by 20:40 UTC.
- The GitHub Enterprise Importer service was degraded, with some users experiencing migration failures during git push operations and most users experiencing delayed migration processing.
- Initiation of new trials for GitHub Enterprise Cloud with Data Residency were also delayed during this time.
- Copilot Metrics via the API could not access the downloadable link during this time. There were approximately 100 requests during the incident that would have failed the download. Recovery began around 20:25 UTC.

We were able to apply a number of mitigations to reduce impact over the course of the incident, but we did not achieve 100% recovery until our service provider’s incident was resolved.

We are working to reduce critical path dependencies on the service provider and gracefully degrade experiences where possible so that we are more resilient to future dependency outages.
Posted Oct 29, 2025 - 23:15 UTC

Investigating

We are investigating reports of degraded performance for Actions
Posted Oct 29, 2025 - 16:17 UTC
This incident affected: Actions.